Ya puedes instalar Xposed en Android Oreo 8.0 y 8.1, descubre cómo

Instalar Xposed Oreo

La llegada de Xposed a Android Nougat se demoró mucho. A pesar de llevar ya más de un año en el mercado hace poco tiempo que Xposed funciona de forma “estable” para Android Nougat pero su llegada a Oreo es muy diferente.

Los usuarios que tengan un móvil con Android Oreo, tanto en la versión 8.0 como en la 8.1, ya podrán probar la versión beta de Xposed para su sistema y lo cierto es que rovo89 asegura que funciona bastante bien. Tenemos que recordar que es una beta y contiene algunos fallos como pequeños parones en las aplicaciones pero eso es completamente normal y no impide el funcionamiento de este framework.

Si tienes un Pixel 2, un OnePlus 5 o alguno de esos móviles que han recibido Android Oreo gracias a LineageOS quizás te interese seguir leyendo. Te recordamos cómo instalar Xposed para que puedas disfrutar de la personalización de Android al máximo.

Xposed para Android Oreo

¿Cómo instalar Xposed en Android Oreo?

Instalar Xposed en un móvil es muy simple, lo difícil son los pasos que hay que realizar antes de proceder a su instalación ya que para poder instalar este framework se necesita ser usuario root.

Aquí tienes un tutorial para ser root de forma fácil en una gran cantidad de móviles y otro para instalar TWRP en muchos de ellos. Ambos tutoriales te podrían venir bien si no has dado los pasos previos que son rootear el móvil e instalar un recovery personalizado para flashear los zips.

Lee también:  Shizuku: una aplicación de Superusuario para tu Android no rooteado

Una vez tengas el instalador necesitarás instalar el zip de tu versión. Para Android Oreo 8.0 necesitarás el SDK 26 mientras que para Android 8.1 Oreo necesitarás el SDK 27.

Lo mejor es flashear estos zips desde TWRP, un recovery personalizado que suele estar disponible para la mayoría de móviles del mercado. Una vez se lance la versión final de Xposed para Oreo también nos comentan que se lanzará el código fuente del mismo.

Algunos módulos podrían no funcionar en Oreo

Como Android Oreo es una distribución bastante nueva es normal que muchos de los desarrolladores todavía no hayan tenido tiempo para adaptar algunos de sus módulos.

Es posible que algunos módulos no sean compatibles con la última versión de Xposed ya que algunos ni se han lanzado todavía para Nougat aunque muchos como Amplify, Swiss Army Knife y GravityBox suelen ser bastante rápidos en las adaptaciones.