android-gingerbread

Google está dando grandes pasos y lo cierto es que ha llegado el momento de dejar atrás el pasado. Los desarrolladores de Android están muy lastrados por tener que adaptar ciertas aplicaciones a versiones antiguas de Android y no hablo de Lollipop que está instalado en, prácticamente, la mitad de androides del mercado, hablo de versiones antiguas de Android con cuotas de uso ridículas.

Sí, en concreto hablo de Android Gingerbread 2.3, una versión antigua que está en menos del 2% de móviles pero con la que Google Play todavía es compatible. Google ha dado un gran paso y ha anunciado en su blog de desarrolladores que la versión 10.0.0 del marco de servicios de Google será la última que soporte Android 2.3 Gingerbread.

Google Play

Los servicios de Google Play 10.2.0 ya no soportarán Gingerbread

A partir de la versión 10.2.0 será necesario contar, al menos, con Android Ice Cream Sandwich 4.0.1 para poder acceder a Google Play de forma oficial. Sí, este cambio se producirá a principios de 2017 y supone un cambio importante para las herramientas de desarrollo de Android.

Android Gingerbread lleva casi 6 años en el mercado y muchos desarrolladores ya no hacen sus apps compatibles con este producto. Lo cierto es que eliminar esta versión de Android del panorama (tiene bastante sentido hacerlo) significa lanzar unas herramientas de desarrollo de Android más veloces y más capaces, más fáciles de adaptar nuevos programas para todas las versiones de Android.

Android Gingerbread, más usado que Nougat

Sí, quizás actualmente estén más o menos parejos pero lo cierto es que la cifra de Gingerbread es de 1,3% de móviles Android y eso significa que miles de personas todavía lo usan. A partir de principios de 2017 puede que Google Play siga funcionando durante un tiempo pero el SDK ya no será compatible con esta versión y es probable que estos móviles no sean capaces de acceder a Google Play.

Gingerbread hace mucho tiempo que es una versión de Android obsoleta y este es un gran paso. No estamos felices porque miles de personas se queden sin Google Play pero es necesario para que el desarrollo de Android sea cada más rápido y universal. Google Play no será compatible con Froyo ni con Honeycomb, ha llegado el momento de que la API mínima soportada sea la API 14.

    COMENTARIOS