Instalar Xposed en una tablet de Amazon sin custom recovery

Android 5.1 ya se puede descargar de forma oficial y con este lanzamiento nos hemos empezado a preocupar por la compatibilidad del framework más utilizado, Xposed. Android 5.1 no trae muchas características nuevas pero sus mejoras son más que evidentes y es indispensable actualizar si estás utilizando la versión anterior, pues Android 5.0 tiene un montón de fallos y problemas.

Xposed ya es compatible con Android 5.0 en su alpha 2 por lo que, con este lanzamiento inesperado, su desarrollador ha hablado de sus intenciones de llevar Xposed a Android 5.1 y lo cierto es que su principal prioridad es hacer estable la versión compatible con Android 5.0 y más tarde se dedicará a programar para que sea también compatible con Android 5.1.

Rovo89 tiene dos razones por las cuales todavía no es capaz de hablar de un calendario para la compatibilidad de Xposed con Android 5.1:

  • Todavía no ha experimentando con Android 5.1 – Trabajar en Xposed consiste en analizar el código de AOSP y en este sistema hay archivos cerrados y un montón de trabas por el camino que le llevan a hacer una gran cantidad de pruebas con muchos errores, en este caso todavía no ha experimentado con Android 5.1 y no sabe cuantificar si hay mucho o poco trabajado por delante.
  • Tiene poco tiempo – Su creador tiene muchos compromisos y no va a sacrificar su vida privada para este proyecto, hay semanas en las que apenas puede dedicar una hora a este desarrollo pero muy pronto publicará más información para que otros desarrolladores puedan contribuir en el proyecto y acelerar el proceso.

Mientras tanto todos los que quieran disfrutar de Xposed deben saber que la alpha 2 de este framework ya es mucho más estable que la anterior versión pero sigue siendo recomendable usarla en versiones basadas en AOSP o Android Stock, pues las ROMs personalizadas como TouchWiz de Samsung pueden dar muchos fallos y llevarnos a errores irrevocables que solo se podrían corregir reinstalando la ROM del terminal.

Xposed es un framework que requiere root para poder ser utilizado pero, a cambio, añade un montón de posibilidades a tu terminal que nunca antes te habrías podido imaginar.  ¿Estás dispuesto a actualizar a Android 5.1 y renunciar a Xposed? ¿Vas a esperar a que se hable de forma oficial sobre la compatibilidad con este nuevo sistema operativo?

Más información | XDA Developers

    COMENTARIOS